Increased API latency
Resolved·Degraded performance

The team has fixed the latency on the API.

Fri, Aug 8, 2025, 09:18 PM
(1 month ago)
·
Affected components
Website
API
Updates

Resolved

The team has fixed the latency on the API.

Fri, Aug 8, 2025, 09:18 PM

Monitoring

The team has fixed the latency on the API.

Fri, Aug 8, 2025, 09:16 PM

Monitoring

We have implemented an update and are now monitoring

Fri, Aug 8, 2025, 08:31 PM(45 minutes earlier)

Investigating

The team is investigating latency on the API. The dashboard experience for customers is impacted but mission critical services are unaffected. Investigation ongoing.

Fri, Aug 8, 2025, 08:06 PM(24 minutes earlier)